Пример 4: Течение из дымовой трубы 

Руководство
Это руководство включает в себя:
· Возможности примера 4
· Общее представление о проблемах решателя
· Описание процесса стационарной симуляции в ANSYS CFX-Pre
· Получение решения в случае стационарной симуляции
· Описание процесса нестационарной симуляции в ANSYS CFX-Pre
· Получение решения в случае нестационарной симуляции
· Визуализация результатов в ANSYS CFX-Post
Перед тем как запустить файл сессии, скопируйте файлы для примера из папки C:\Program Files\ANSYS Inc\v121\CFX\examples в Вашу рабочую директорию.
Вам потребуется скопировать следующие файлы:
· CircVent.pre
· CircVentMesh.gtm
Возможности Примера 4 

Этот пример использует следующие возможности ANSYS CFX.
	Component
	Feature
	Details

	ANSYS CFX-Pre
(препроцессор)
	User Mode
(Пользовательский режим)
	General Mode 
(Основной режим)

	
	Simulation Type
(Тип симуляции)
	Steady State 
(Стационарный)

	
	
	Transient 
(Нестационарный)

	
	Fluid Type
(Тип жидкой среды)
	General Fluid 
(Основная жидкая среда)

	
	Domain Type
(Тип домена)
	Single Domain 
(Один домен)

	
	Turbulence Model
(Модель турбулентности)
	k-Epsilon 

	
	Boundary Conditions
(Граничные условия)
	Inlet (Subsonic) 
Вход (дозвуковой)

	
	
	Opening 
(Граница, пропускающая жидкость в обе стороны)

	
	
	Wall: No-Slip 
Стенка: Без скольжения

	
	Timestep
(Шаг по времени)
	Auto Time Scale 
(Автоматическая временная шкала)

	
	
	Transient Example 
(Нестационарный пример)

	
	Transient Results File 
(Временный файл результатов)
	

	ANSYS CFX-Post
(постпроцессор)
	Plots
(Схемы)
	Animation 
(Анимация)

	
	
	Isosurface 
(Изоповерхность)

	
	Other
(Другое)
	Auto Annotation 
(Автоматическая аннотация)

	
	
	MPEG Generation 
(Генерация фильма)

	
	
	Printing 
(Печать)

	
	
	Time Step Выберитеion 
(Выборка шагов по времени)

	
	
	Title/Text 
(Заголовок/текст)

	
	
	Transient Animation 
(Временная анимация)


В этом руководстве Вы изучите:

· Настройки в случае нестационарной симуляции.

· Использование открытого типа граничных условий  в препроцессоре ANSYS CFX-Pre.

· Моделирование дыма с помощью дополнительных переменных в препроцессоре ANSYS CFX-Pre.

· Визуализация дыма с помощью изоповерхности в постпроцессоре ANSYS CFX-Post.
· Создание изображения для печати, генерация файла MPEG в постпроцессоре ANSYS CFX-Post.
Общее представление о проблемах решателя
В этом примере из дымовой трубы выходит дым, который распределяется в атмосфере воздушным потоком. В отличие от предыдущих примеров, в которых рассматривались стационарные процессы, здесь есть зависимость от времени. В начальном состоянии дыма нет. Затем он начинает выходить из дымовой трубы и появляется над ней, его рассеивание зависит от времени. 
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Описание стационарной симуляции в препроцессоре ANSYS CFX-Pre 

В этом разделе будет пошагово описан процесс задания физики для стационарного процесса, когда дым еще не появляется выше трубы. Результат этой симуляции будет использоваться в качестве начального расчета для нестационарной задачи. 

Создание новой симуляции 

Стандартный запуск ANSYS CFX-Pre через ANSYS CFX-12.0 Lancher 

1. Если это необходимо, запустите ANSYS CFX-12.0 Lancher.

2. Нажмите кнопку CFX-Pre 12.0 в ANSYS CFX-12.0 Lancher.

3. Выберите File > New Case (Файл > Новая симуляция). 

4. Выберите General в диалоговом окне с названием New Case и нажмите OK. 

5. Выберите File > Save Case As (Файл > Сохранить симуляцию как…). 

6. В поле ввода File name задайте имя CircVentIni и нажмите Save (Сохранить). 

7. Далее переходим к импорту сетки. 

Импорт сетки  

Действия 

1. Выберите File > Import > Mesh (Файл > Импорт сетки) или нажмите правой кнопкой мыши на вкладке Outline на пункт Mesh и выберите Import Mesh. 

2. В диалоговом окне Import Mesh выберите файл CircVentMesh.gtm в Вашей директории. 

3. Нажмите Open (Открыть). 

4. Нажмите правую кнопку мыши в области окна просмотра и выберите пункт Predefined Camera > Isometric View (Z up) (Расположение камеры > Ось Z направлена вверх). 
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Создание дополнительных переменных 

В этом примере будут использоваться дополнительные переменные для модели рассеивания дыма в трубе. 

Примечание
В стационарной симуляции заранее включим значение по времени для интерполяции, которое будет использоваться в нестационарной симуляции. 

1. Выберите в главном меню пункт Insert > Expressions, Functions and Variables > Additional Variable (Вставка > Выражения, функции и переменные > Дополнительные переменные) или нажмите на кнопку Additional Variable (Дополнительные переменные) [image: image3.png]


. 

2. Укажите имя переменной smoke (Дым). 

3. Нажмите OK. 
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4. В качестве типа переменной Variable Type выберите Volumetric (Объемный). 

5. Задайте единицы измерения Units - [kg m^-3]. 

6. Нажмите OK. 

Создание домена 

Ниже будет создан домен с помощью дополнительной переменной smoke (Дым).
Действия 

1. Выберите Insert > Domain (Вставка > Домен) в главном меню или нажмите Domain (Домен) [image: image5.png]


, задайте имя CircVent (Дымовая труба) и нажмите OK. 

2. Примените следующие настройки
	Tab
	Setting
	Value

	Basic Settings
(Общие настройки)
	Location and Type > Location
	B1.P3

	
	Fluid and Particle Definitions
	Fluid 1

	
	Fluid and Particle Definitions > Fluid 1 > Material 
	Air at 25 C
(Воздух, 25 С)

	
	Domain Models > Pressure > Reference Pressure 
(Относительное давление)
	0 [atm]
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	Fluid Models 
(Модель расчета течения жидкой среды)
	Heat Transfer > Option
(Перенос тепла > Опции)
	None
(Нет)

	
	Additional Variable Models > Additional Variable 

	smoke

	
	Additional Variable Models > Additional Variable > smoke 
(Настройки дополнительных переменных > дым)
	(Selected)
(Поставьте галочку)

	
	Additional Variable Models > Additional Variable > smoke > Kinematic Diffusivity 
(Настройки дополнительных переменных > дым > Кинематическая диффузия)
	(Selected)
(Поставьте галочку)

	
	Additional Variable Models > Additional Variable > smoke > Kinematic Diffusivity > Kinematic Diffusivity 
(Настройки дополнительных переменных > дым > Кинематическая диффузия > Кинематическая диффузия)
	1.0E-5 [m^2 s^-1] [1]
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3. [1] 1.0E-5 [m^2 s^-1] is a representative kinematic diffusivity value for smoke in air. 

4. Нажмите OK. 

Создание граничных условий 

Это пример внешнего течения, т.к. газ течет над объектом, а не внутри ограниченного объекта. В этом случае некоторые входы будут созданы с достаточно большими размерами, чтобы они не влияли на решения газодинамики. Однако, масштабы шкал значений создаются в опциях Default Intensity and AutoCompute Length Scale для турбулентности и зависят от размеров входа.. Они являются приближением для расчета внешнего течения и особенно, течения в цилиндрических трубах. Таким образом, Вам необходимо установить интенсивность турбулентности и масштаб шкалы достаточно точно для большого размера входов в задачах с внешним течением. Если у Вас нет необходимых значений для масштаба шкалы, Вы можете использовать масштаб, основываясь на типовых размерах объекта, над которым рассматривается течение. В этом случае, Вы будете использовать масштаб шкалы турбулентности, деление которой соответствует 1/10 диаметра трубы. 

Создание граничного условия Inlet (Вход) 

1. Выберите в главном меню пункт Insert > Boundary (Вставка > Граничные условия) или нажмите на кнопку на панели инструментов Boundary (Граничные условия) [image: image8.png]


. 
2. В качестве имени Name задайте Wind(Ветер).
3. Нажмите OK. 

4. Примените следующие настройки
	Tab
	Setting
	Value

	Basic Settings 
	Boundary Type
(Тип границы)
	Inlet
(Вход)

	
	Location
(Участок)
	Wind
(Ветер)

	Boundary Details
	Mass and Momentum > Option
(Уравнения масс и момента > Опции)
	Cart. Vel. Components
(Компоненты вектора скорости)

	
	Mass and Momentum > U
(Уравнения масс и момента > U)
	1 [m s^-1]

	
	Mass and Momentum > V
(Уравнения масс и момента > V)
	0 [m s^-1]

	
	Mass and Momentum > W
(Уравнения масс и момента > W)
	0 [m s^-1]

	
	Turbulence > Option
(Турбулентность > Опции)
	Intensity and Length Scale
(Интенсивности и шкала длин)

	
	Turbulence > Fractional Intensity
(Турбулентность)
	0.05 [1]

	
	Turbulence > Eddy Length Scale 
(Турбулентность > Шкала длин вихревого течения)
	0.25 [m] [1]

	
	Additional Variables > smoke > Option
(Дополнительные переменные > Дым > Опции)
	Value

	
	Additional Variables > smoke > Add. Var. Value 
(Дополнительные переменные > Дым > Значение)
	0 [kg m^-3] [2]


5. Нажмите OK. 
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Создание граничного условия Opening (Открытый) 

1. Выберите в главном меню пункт Insert > Boundary (Вставка > Граничные условия) или нажмите на кнопку на панели инструментов Boundary (Граничные условия) [image: image10.png]


. 

2. В качестве имени Name задайте Atmosphere (Атмосфера).
3. Нажмите OK. 

4. Примените следующие настройки
	Tab
	Setting
	Value

	Basic Settings 
	Boundary Type
(Тип границы)
	Opening
(Открытый)

	
	Location
(Участок)
	Atmosphere
(Атмосфера)

	Boundary Details
	Mass and Momentum > Option
(Уравнения масс и момента > Опции)
	Opening Pres. and Dirn
(Давление на открытой границе)

	
	Mass and Momentum > Relative Pressure
(Уравнения масс и момента > Относительное давление)
	0 [Pa]

	
	Flow Direction > Option
(Направление течения > Опции)
	Normal to Boundary Condition
(Нормаль к граничному условию)

	
	Turbulence > Option
(Турбулентность > Опции)
	Intensity and Length Scale 
(Интенсивности и шкала длин)

	
	Turbulence > Fractional Intensity
	0.05

	
	Turbulence > Eddy Length Scale
(Турбулентность > Шкала длин вихревого течения)
	0.25 [m]

	
	Additional Variables > smoke > Option
	Value

	
	Additional Variables > smoke > Add. Var. Value
	0 [kg m^-3]


5. Нажмите OK. 
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Создание граничного условия Inlet (Вход) для трубы 

1. Выберите в главном меню пункт Insert > Boundary (Вставка > Граничные условия) или нажмите на кнопку на панели инструментов Boundary (Граничные условия) [image: image12.png]


. 

2. В качестве имени Name задайте Vent(Труба).
3. Нажмите OK. 

4. Примените следующие настройки

	Tab
	Setting
	Value

	Basic Settings 
	Boundary Type
	Inlet

	
	Location
	Vent

	Boundary Details
	Mass And Momentum > Normal Speed
	0.01 [m s^-1]

	
	Turbulence > Option
	Intensity and Eddy Viscosity Ratio

	
	Turbulence > Fractional Intensity
	0.05

	
	Turbulence > Eddy Viscosity Ratio
	10

	
	Additional Variables > smoke > Option
	Value

	
	Additional Variables > smoke > Add. Var. Value 
	0 [kg m^-3]


5. Нажмите OK. 
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Настройка начальных значений 

Действия 

1. Нажмите Global Initialization (Глобальная инициализация) [image: image14.png]


. 
2. Просмотрите закладки. Настройки остаются по умолчанию.
3. Нажмите OK.
Настройки параметров решателя 

В решателе ANSYS CFX-Solver есть возможность задать физический шаг по времени для стационарного случая. Если Вы не знаете размер шага по времени для Вашей задачи, то можно использовать опцию Auto Timescale (Автоматическая временная шкала). 

Действия 

1. Нажмите Solver Control (Контроль решателя) [image: image15.png]


. 

2. Примените следующие настройки

	Вкладка
	Параметр
	Значение

	Basic Settings
(Основные настройки)
	Convergence Control > Max. Iterations
(Управление сходимостью > Максимальное количество итераций)
	75


3. Нажмите OK. 

Запись файла для решателя (.def) 

Действия 

1. Нажмите Write Solver File (Записать файл для решателя) [image: image16.png]


. 
2. Примените следующие настройки:

	Параметр
	Значение

	File name
(Имя файла)
	CircVentIni.def

	Quit CFX–Pre[a]
(Закрыть CFX–Pre)
	(Поставьте галочку)

	[a] Если запустили ANSYS CFX-Pre из ANSYS CFX-.12.0 Laucher.  


3. Если вы получили сообщение о том, что файл уже существует, нажмите Overwrite (Перезаписать). 

4. Нажмите Yes (Да) или Save & Quit (Сохранить и закрыть приложение), чтобы сохранить CircVentIni.cfx. 

Получение решения для стационарной задачи 
Когда ANSYS CFX-Pre закроется. 
1. Запустите ANSYS CFX-Solver Manager, выберите файл CircVentIni.cfx.
2. Нажмите Start Run (Начать расчет). 
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Вы увидите графики для 6 уравнений: U - Mom, V - Mom, W - Mom, P - Mass, K-TurbKE и E-Diss.K (3 уравнения сохранения момента, уравнение сохранения масс и уравнение для расчета кинетической энергии турбулентности и турбулентности рассеивания вихревого течения). Вкладка Momentum and Mass содержит 4 графика, другие две вкладки касаются параметров турбулентности Turbulence Quantities. Для переменных дыма также строятся графики, но значения не регистрируются, т.к. они не были инициализированы. 

3. Нажмите No (Нет), чтобы закрыть решатель, т.к. Вам не нужно просматривать результаты в постпроцессоре ANSYS CFX-Post. 
Далее Вы загрузите симуляцию в препроцессор ANSYS CFX-Pre для описания нестационарной задачи.
Описание нестационарной задачи в ANSYS CFX-Pre
В этом разделе Вы откроете настройки стационарной симуляции и измените модель на нестационарную. 

Открытие существующей симуляции 

1. Если это необходимо, запустите ANSYS CFX-12.1 Lancher.

2. Нажмите кнопку CFX-Pre 12.1 в ANSYS CFX-12.1 Lancher.

3. Выберите File > Open Case  (Файл > Открыть симуляцию). 

4. Если это необходимо, укажите путь к рабочей директории.
5.  Выберите файл симуляции CircVentIni.cfx.
6. Нажмите Open (Открыть).
7. Выберите File > Save Case  As (Файл > Сохранить симуляцию как…). 

8. В поле ввода File name измените имя на CircVent и нажмите Save (Сохранить). 
Изменение типа симуляции 

На этом шаге Вы создадите нестационарную задачу. 
Затем Вы установите концентрацию дыма, экспоненциально зависящую от времени. Необходимо будет убедиться, что интервал шага по времени меняется он начала симуляции к ее концу. 

1. Нажмите Simulation Type (Тип симуляции) [image: image18.png]


. 

2. Примените следующие настройки
	Вкладка
	Параметр
	Значение

	Basic Settings
(Основные настройки)
	Analysis Type > Option
(Тип анализа > Опции)
	Transient
(Нестационарный)

	
	Analysis Type > Time Duration > Total Time
(Тип анализа > Продолжительность > Полное время)
	30 [s]

	
	Analysis Type > Time Steps > Timesteps[a][b]
(Тип анализа > Шаги по времени > Шаги по времени)
	4*0.25, 2*0.5, 2*1.0, 13*2.0 [s]

	
	Analysis Type > Initial Time > Option 
	Value

	
	Analysis Type > Initial Time > Time
(Тип анализа > Начальное значение времени > Время)
	0 [s]

	[a] Не нажимайте кнопку Enter Expression  (Ввод выражения) 
[image: image19.png]


 для ввода списка величин. Список значений задается сначала без единицы измерения, она указывается потом из выпадающего списка. 

[b] Этот список означает, что необходимо сделать 4 шага по 0.25 [s], затем 2 шага по 0.5 [s], и т.д. 


3. Нажмите OK. 

Изменение граничных условий
1. На вкладке Outline в дереве просмотра раскройте Simulation > CircVent > Vent. 

2. Нажмите правой кнопкой мыши на пункт Vent и выберите Edit (Правка). 

3. Примените следующие настройки
	Вкладка
	Параметр
	Значение

	Boundary Details
(Детали)
	Mass and Momentum > Normal Speed
(Уравнения масс и момента > Нормальная скорость)
	0.2 [m s^-1]


4. Оставьте детали для Vent открытыми.

5. Вам необходимо задать выражение для концентрации дыма. Концентрация равна 0 для времени t=0 и достигает максимального значения равного 1 kg m^-3. 

6. Создадим новое выражение: выберите в главном меню Insert > Expressions, Functions and Variables > Expression (Вставка > Выражения, функции и переменные > Выражение). Укажите имя TimeConstant (Постоянная времени).  

7. Примените следующие настройки
	Name
(Имя)
	Definition
(Описание)

	TimeConstant
	3 [s]


8. Нажмите Apply (Применить). 
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9. Аналогично создайте еще два выражения и примените следующие настройки: 

	Name
	Definition

	FinalConcentration
(Финальная концентрация)
	1 [kg m^-3]

	ExpFunction[a]
(Экспоненциальная функция)
	FinalConcentration*abs(1-exp(-t/TimeConstant))

	[a] После ввода этой функции выберите в окне описания операндов Definition тип выражения Expression. Имена переменных и констант, которые используются в выражении, выберите в меню под Expressions (Выражения). Функции exp (Экспонента) и abs (Модуль) находятся в Functions > CEL. Переменная t находится в Variables (Переменнаые). 


Далее визуализируем заданное выражение концентрации дыма, вытекающего из трубы.

Построение графика концентрации дыма 

1. Нажмите дважды на пункт ExpFunction под Expressions (Выражения) в дереве просмотра. 

2. Примените следующие настройки
	Вкладка
	Параметр
	Значение

	Plot
(график)
	t
	(Поставьте галочку)

	
	Start of Range
(Начальное значение)
	0 [s]

	
	End of Range
(Конечное значение)
	30 [s]


3. Нажмите Plot Expression (Построить график выражения). 
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1. Можно заметить, что концентрация дыма изменяется экспоненциально и достигает 90% от конечной величины за 7 секунд.

2. Выберите вкладку Boundary: Vent (Граничные условия: Труба). 

На следующем шаге Вы укажите выражение ExpFunction в качестве дополнительной переменной smoke для граничного условия Vent (Труба). 

3. Примените следующие настройки
	Вкладка
	Параметр
	Значение

	Boundary Details
(Детали)
	Additional Variables > smoke > Option
(Дополнительные переменные > Дым > Опции)
	Value
(Значение)

	
	Additional Variables > smoke > Value[a]
(Дополнительные переменные > Дым > Значение)
	ExpFunction

	[a] Нажмите Enter Expression (Ввод выражения) 
[image: image22.png]


, чтобы ввести текст. 


4. Нажмите OK. 

Инициализация значений 

В стационарной симуляции, которую Вы уже рассчитали, использовалась поддержка инициализации значений решателем ANSYS CFX-Solver. Вы можете оставить инициализацию всех данных, установив значение Automatic (Автоматически), тогда инициализация значений будет считана автоматически из файла инициализации значений. Поэтому, нет необходимости пересматривать таблицу инициализации. 

Изменение параметров решателя 

1. Нажмите Solver Control (Контроль решателя) [image: image23.png]


. 

2. Установите параметр Convergence Control > Max. Coeff. Loops (Управление сходимостью > Максимальный коэффициент цикла) равный 3. 

3. Оставьте остальные настройки значений по умолчанию.

4. Нажмите OK. 

Контроль выходных параметров 

Чтобы Вы имели возможность просмотреть в различные моменты времени результ вычислений (а не только последний результат), необходимо создавать временные файлы с результатами. Временные файлы могут содержать не полностью все данные решения, а только некоторые величины. Ниже Вы создадите минимальный файл результатов. 

Создание минимального файла с временными результатами
1. Выберите в главном меню пункт Insert > Solver > Output Control (Вставка > Решатель > Выходные параметры). 

2. Перейдите на вкладку Trn Results (Временные результаты). 

3. Нажмите на кнопку Add new item (Добавить новый компонент) [image: image24.png]


 и нажмите OK, чтобы создать объект с заданным по умолчанию именем. 

Таким образом, Вы создали временный файл результатов. 
4. Примените следующие настройки для объекта Transient Results 1
	Параметр
	Значение

	Option
(Опции)
	Selected Variables
(Переменные)

	Output Variables List[a]
(Список выходных переменных) 
При задании удерживайте кнопку Ctrl
	Pressure, Velocity, smoke
(Давление, Скорость, Дым)

	Output Frequency > Option
(Частота сохранения значений выходных параметров > Опции)
	Time List
(Список временных интервалов)

	Output Frequency > Time List[b]
(Частота сохранения значений выходных параметров > Список  временных интервалов)
	1, 2, 3 [s]

	[a] Нажмите на картинку с эллипсом, чтобы выбрать компоненты ,если они не отобразились в выпадающем списке. Используйте клавишу <Ctrl>, чтобы выбрать несколько компонентов. 
[b] Не нажимайте кнопку Enter Expression  (Ввод выражения) 
[image: image25.png]


 для ввода списка величин. Список значений задается сначала без единицы измерения, она указывается потом из выпадающего списка.
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5. Нажмите Apply (Применить). 

6. Создайте аналогично второй объект с именем Transient Results 2 и примените следующие настройки для него
	Параметр
	Значение

	Option
(Опции)
	Selected Variables
(Переменные)

	Output Variables List
(Список выходных переменных)
	Pressure, Velocity, smoke
(Давление, Скорость, Дым)

	Output Frequency > Option
(Частота сохранения значений выходных параметров > Опции)
	Time Interval
(Интервал времени)

	Output Frequency > Time Interval[a]
(Частота сохранения значений выходных параметров > Интервал времни)
	4 [s]

	[a] Временный файл результатов будет записываться каждые 4 секунды (включая момент 0 секунд) и 1 s, 2 s and 3 s. Файлы будут содержать не сетку, а данные только для переменных из списка. Это минимизирует размер файла. Полный файл результатов будет записан только в конце задачи. 


7. Нажмите OK. 

Запись файла для решателя (.def) 

Действия 

1. Нажмите Write Solver File (Записать файл для решателя) [image: image27.png]


. 
2. Примените следующие настройки:

	Параметр
	Значение

	File name
(Имя файла)
	CircVent.def

	Quit CFX–Pre[a]
(Закрыть CFX–Pre)
	(Поставьте галочку)

	[a] Если запустили ANSYS CFX-Pre из ANSYS CFX-.12.1 Laucher.  


3. Убедитесь что выбран пункт Start Solver Manager (Запустить Менеджер задач) и нажмите Save (Сохранить).  

4. Если вы получили сообщение о том, что файл уже существует, нажмите Overwrite (Перезаписать). 

5. Нажмите Yes (Да) или Save & Quit (Сохранить и закрыть приложение), чтобы сохранить симуляцию с расширением (.cfx).
Получение нестационарного решения 
В этом примере ANSYS CFX-Solver будет считывать инициализацию значений из файла. 
В диалоговом окне Define Run указывается автоматически файл описания (Definition File) из ANSYS CFX-Pre: CircVent.def. 
Заметим, то выходной файл, сгенерированный ANSYS CFX-Solver, будет большего размера, чем файл для стационарной задачи. Потому что каждый шаг по времени состоит из нескольких внутренних итераций. В конце каждого шага информация о различных качественных характеристиках будет выводиться в область просмотра выходного файла. 

1. В поле ввода Initial Values File (Файл инициализации переменных), нажмите Browse(Обзор) [image: image28.png]


. 

2. Выберите файл результатов CircVentIni_001.res, который был создан при решении стационарной задачи.
3. Нажмите Open (Открыть). 

4. Нажмите Start Run (Запустить расчет).
5. Вы могли заметить, что из файла инициализации также используется сетка. Сетка аналогична той, которая использовалась в файле описания. Нажмите OK.
Запустится решатель ANSYS CFX-Solver. Процесс расчета может занять достаточно продолжительное время, в зависимости от характеристик Вашего компьютера. При завершении процесса решения появится диалоговое окно. 

6. После завершения вычислений появится сообщение с вопросом: «Вы хотите просмотреть результаты вычислений?» Если Вы нажмете No (Нет), то ANSYS CFX-Solver останется открытым, и Вы можете продолжить работу в нем. Просмотреть результаты Вы можете на вкладке Out File решателя. 

Просмотр результатов в постпроцессоре ANSYS CFX-Post 

В этом примере Вы увидите рассеивание дыма в различные моменты времени. Когда ANSYS CFX-Post загрузится, будут доступны результаты финального шага, т.е. в момент времени t = 30 s. 

Создание изоповерхности 

Изоповерхность – это поверхность с одинаковым значением какой-либо переменной. Это может быть поверхность, содержащая точки, в которых скорость равна 1 [m s^-1]. В этом примере Вы создадите поверхность с распределением переменной smoke (Дым) - дополнительная переменная, которую Вы ранее указали. 

1. Нажмите правую кнопку мыши в области окна просмотра и выберите Predefined Camera > Isometric View (Z up) (Расположение камеры > По направлению оси Z). 

2. Выберите в главном меню пункт Insert > Location > Isosurface (Вставка > Участок > Изоповерхность) или под списком Location (Участок) нажмите Isosurface (Изоповерхность). 

3. Нажмите OK. 

4. Примените следующие настройки
	Вкладка
	Параметр
	Значение

	Geometry
(Геометрия)
	Variable
(Перемнная)
	Smoke
(Дым)

	
	Value
(Значение)
	0.005 [kg m^-3]


5. Нажмите Apply (Применить). 

· Неровная поверхность отобразится в окне просмотра, дым начнет появляться из трубы.

· Поверхность будет неровной, поскольку сетка грубая. Для сглаживания поверхности необходимо пересчитать задачу с более мелкой сеткой. 

· Поверхность раскрашена в один цвет, указанный по умолчанию на вкладке Color (Цвет). 

· Когда для цветового режима Color Mode установлены параметры Constant (Константа) или Use Plot Variable (Использовать график переменной) для изоповерхности, то поверхность отображается одним цветом. 

6. Поэкспериментируйте на вкладке Geometry (Геометрия), изменяя значения параметра Value (Значения), и Вы увидите как дым рассеивается более ясно. 

Измените масштаб и поворот объекта в окне просмотра как это необходимо.

7. Установите значение Value равное 0.002 [kg m^-3]. 

8. Нажмите правую кнопку мыши в области окна просмотра и выберите Predefined Camera > Isometric View (Z up) (Расположение камеры > По направлению оси Z). 

Просмотр результатов в разные моменты времени 

Параметр Timestep Selector показывает число временных шагов Time Step (Внешний цикл), параметры Time Value (Время симуляции в секундах) и  Type (Тип) файла результатов показывают на каком шаге был сохранен файл. Вы можете заметить, что временные файлы результатов Partial сохранялись для каждого шага по времени, исключая последний шаг (как было указано в ANSYS CFX-Pre). 

1. Нажмите Timestep Selector (Выбор шага по времени) [image: image29.png]


. 

2. Загрузите результаты для шага по времени равного 2 s, щелкнув дважды на соответствующей строке в Timestep Selector (Выбор шага по времени). 

После короткой паузы пункт Current Timestep (Текущий шаг по времени), расположенный ниже панели заголовка Timestep Selector (Выбор шага по времени) будет обновлен для нового числа шагов. 

3. Загрузите значение времени 4 s, используя Timestep Selector (Выбор шага по времени). 

Дым распространится еще больше, и будет развеваться по ветру.

4. Нажмите дважды на любых других значениях времени, чтобы увидеть как увеличивается распространение дыма с течением времени.

5. В конце загрузите значение времени 1 s.

Генерация выходного файла 

Вы можете создать в качестве выходного файла изображение в ANSYS CFX-Post.

Добавление заголовка 

Во-первых, добавьте текст в окно просмотра, чтобы он присутствовал на изображении как заголовок.

1. Выберите пункт Insert > Text (Вставка > Текст) из главного меню или нажмите Create text (Создать текст)[image: image30.png]ad



. 

2. Нажмите OK. 

3. В поле вода строки Text String введите следующий текст. 

Изоповерхность, показывающая концентрацию дыма 0.002 kg/m^3
Примечание
Текст будет добавлен после выполнения пунктов ниже.
4. Выберите Embed Auto Annotation (Автоматическое создание аннотации). 

5. Установите для параметра Type  (Тип) значение Time Value (Значение времени). 

In the text line, note that <aa> has been added to the end. This is where the time value will be placed. 

6. Нажмите Apply (Применить) для создания заголовка. 

7. Перейдите на вкладку Location (Участок), чтобы изменить расположение заголовка. 

По умолчанию текст заголовка расположен вверху по центру окна 

8. Под пунктом Appearance (Появление, видимость) измените Color Mode (Цветовой режим) на User Specified (Пользовательский) и выберите новый цвет. 

9. Нажмите Apply (Применить). 

Файл JPEG 

ANSYS CFX-Post может создать выходные результаты в нескольких форматах. В следующем разделе Вы сохраните изображение в формате JPEG.

1. Убедитесь, что загружены результаты для шага времени 1 s.

2. Выберите File > Print (Файл > Печать) или нажмите Print (Печать)[image: image31.png]


. 

3. Укажите формат Format JPEG. 

4. Нажмите кнопку Browse (Обзор)[image: image32.png]


 в окне File (Файл). 

5. Укажите директорию, в которую хотите сохранить файл.

6. Введите имя файла.

7. Нажмите Save (Сохранить), чтобы сохранить настройки пути директории  имени файла. 

8. Нажмите Print (Печать), чтобы сохранить файл в формате JPEG. 

Чтобы просмотреть файл или распечатать его на бумаге, воспользутесь приложением, поддерживающим формат JPEG.

9. Удалите текст, чтобы скрыть его.
Создание MPEG файла 

Вы можете создать MPEG файл, чтобы просмотреть распространение дыма во времени. Для создания файла Вам нужно воспользоваться диалоговым окном Animation (Анимация) как в примере 1. Однако, в этом примере анимация будет создаваться по нескольким шагам во времни. 

Примечание
На вкладке Advanced (Дополнительно) выберите в Animation Options  (Опции анимации) пункт Save frames as image files (Сохранять кадры как изображения). Тогда каждый кадр будет сохраняться в формате JPEG или PPM и использоваться для кодирования MPEG при его создании.  

Параметр Keyframes 

1. Нажмите Animation (Анимация)[image: image33.png]


. 

2. Убедитесь, что Keyframe Animation (Покадровая анимация) отмечен галочкой. 

3. Выберите положение объекта, удобное для просмотра рассеивания дыма.

4. В диалоговом окне Animation (Анимация) нажмите New (Новый)[image: image34.png]


, чтобы создать объект KeyFrameNo1. 

5. Загрузите результаты для шага по времени равного 30 s, используя Timestep Selector (Выбор шага по времени). 

6. Нажмите New (Новый)[image: image35.png]


 в диалоговом окне Animation (Анимация), чтобы создать KeyframeNo2. 

Описание дополнительных опций 

В течение процесса создания анимации по времени, будут загружаться результаты различных шагов, и все объекты будут обновляться, чтобы использовать результаты из соответствующего временного файла. Каждый кадр анимации должен использовать существующий шаг по времени. 

В Animation (Анимация) Timestep (Временной шаг) может быть установлен Timestep Interpolation, TimeValue Interpolation or Sequential Interpolation. Эти настройки возможно задавать для каждого кадра. 

1. Нажмите More Animation Options (Дополнительные опции анимации). 

2. Нажмите Options (Опции). 

3. Примените следующие настройки
	Вкладка
	Параметр
	Значение

	Options
(Опции)
	Transient Case[a]
(Нестационарный случай)
	TimeValue Interpolation
(Временное значение интерполяции)

	[a] В этом случае каждый кадр использует временный файл и имеет ограничение по времени. 


4. Нажмите OK. 

5. Нажмите один раз на KeyframeNo1 затем установите # of Frames  27 и нажмите клавишу <Enter>. 

Анимация сейчас состоит из 29 кадров (27 промежуточных кадров и двух объектов keyframes).

6. Выберите Save MPEG (Сохранить в формате MPEG). 

7. Нажмите Browse (Обзор)[image: image36.png]


 . 

8. Укажите имя файла File name CircVent.mpg. 

9. Если требуется, укажите путь к директории.

10. Нажмите Save (Сохранить). 

11. Нажмите To Beginning(К началу)[image: image37.png]


. 

12. Нажмите Play the animation (Проиграть анимацию)[image: image38.png]


. 

· Файл MPEG будет создаваться как анимация (кадр за кадром).

· Скорость проигрывания будет не очень высокой, т.к. необходимо загрузить все объекты для шагов по времени для каждого кадра.

· Для просмотра файла MPEG, воспользуйтесь соответствующим приложением.

13. Когда завершите работу, закройте постпроцессор ANSYS CFX-Post.
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