Пример 6: Течение потока воздуха в разделенной полости 

Руководство
Это руководство включает в себя:
· Возможности примера 6
· Общее представление о проблемах решателя
· Описание процесса симуляции в ANSYS CFX-Pre
· Получение решения с помощью ANSYS CFX-Solver Manager
· Визуализация результатов в ANSYS CFX-Post
Перед тем как запустить файл сессии, скопируйте файлы для примера из папки C:\Program Files\ANSYS Inc\v110\CFX\examples в Вашу рабочую директорию.
Вам потребуется скопировать следующие файлы:
· Buoyancy2D.geo
· Buoyancy2D.pre
Возможности Примера 6
Этот пример использует следующие возможности ANSYS CFX.
	Component
	Feature
	Details

	ANSYS CFX-Pre
(Препроцессор)
	User Mode
(Пользовательский режим)
	General Mode 
(Основной режим)

	
	Simulation Type
(Тип симуляции)
	Transient 
(Нестационарный)

	
	Fluid Type
(Тип жидкой среды)
	General Fluid 
(Основная жидкая среда)

	
	Domain Type
(Тип домена)
	Single Domain 
(Один домен)

	
	Turbulence Model
(Модель турбулентности)
	Laminar 
(Ламинарный)

	
	Heat Transfer
(Перенос тепла)
	Thermal Energy 
(Тепловая энергия)

	
	Buoyant Flow
( течение)
	 

	
	Boundary Conditions
(Граничные условия)
	Symmetry Plane 
(Плоскость симметрии)

	
	
	Outlet (Subsonic) 
Выход (дозвуковой)

	
	
	Wall: No-Slip 
Стенка: без скольжения

	
	
	Wall: Adiabatic 

Стенка: адиабатическая

	
	
	Wall: Fixed Temperature 
Стенка: фиксированная температура

	
	Output Control
(Управление выходными данными)
	 

	
	Timestep
(Шаг по времени)
	Transient Example 
(Временной шаг)


	
	Transient Results File
(Временные файлы результатов)
	 

	ANSYS CFX-Post
(Постпроцессор)
	Plots (Графики, схемы)
	Default Locators 
(Участки по умолчанию)

	
	Report (Отчет)
	 

	
	Other (Другое)
	Time Step Выберитеion 
(Выбор временного шага)

	
	
	Transient Animation 
(Анимация по времни)


В этом руководстве Вы изучите:

· Использовать импорт сетки из CFX-4.

· Задавать время нестационарной симуляции.

· Моделировать buoyant течение.

Общее представление о проблемах решателя
В этом примере демонстрируется возможность ANSYS CFX моделировать buoyancy-driven течения, которое требует дополнительного эффекта гравитации. 

Модель представляет собой разделенную двухмерную полость, содержащую воздух. Снизу полости поддерживается постоянная температура 75°C, а сверху - 5°C. Полость наклонена под углом 30 градусов к горизонтали. Нестационарная симуляция позволяет увидеть, как развивается течение, при задании начальных постоянных условий. Так как в начале расчетов используются стационарные условия, то нет необходимости рассчитывать стационарную симуляцию, чтобы использовать ее результаты как начальные приближения. 
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Сетка для полости была создана в CFX-4.

Описание симуляции в препроцессоре ANSYS CFX-Pre 

Вы импортируете гексаэдрическую сетку, сгенерированную первоначально в CFX-4. Сетка содержит отмеченные регионы, для которых будет возможно применить граничные условия существенные для данной задачи. 

Проигрывание файла сессии 

Чтобы настройки симуляции выполнились автоматически, Вы можете запустить файл сессии. Для этого выберите в главном меню пункт Session > Play Tutorial (Сессия > Проиграть сессию из руководства), затем выберите файл сессии Buoyancy2D.pre. 

Создание новой симуляции 

1. Запустите ANSYS CFX-Pre.

2. Выберите File > New Simulation (Файл > Новая симуляция). 

3. Выберите General в диалоговом окне с названием New Simulation File и нажмите OK. 

4. Выберите File > Save Simulation As (Файл > Сохранить симуляцию как…). 

5. В поле ввода File name задайте имя Buoyancy2D и нажмите Save (Сохранить). 

Импорт сетки  
1. Выберите File > Import Mesh (Файл > Импорт сетки) или нажмите правой кнопкой мыши на вкладке Outline на пункт Mesh и выберите Import Mesh. 

2. В диалоговом окне Import Mesh выберите тип файла (File type) CFX-4 и имя файла  (File name) укажите Buoyancy2D.geo в Вашей директории. 

3. Нажмите Open (Открыть). 

Тип симуляции
По умолчанию настройки для единиц измерения и системы координат соответствуют данному примеру, но тип симуляции необходимо изменить на нестационарный. 

Обратите внимание на сообщения валидатора физики, когда Вы установите тип симуляции нестационарный (Transient). Эти ошибки будут устранены (зафиксированы?) в следующей части примера. 

1. Нажмите Simulation Type (Тип симуляции) [image: image2.png]


. 

2. Примените следующие настройки
	Вкладка
	Параметр
	Значение

	Basic Settings
(Основные настройки)
	Simulation Type > Option
(Тип симуляции > Опции)
	Transient
(Нестационарный)

	
	Simulation Type > Time Duration > Total Time[a]
(Тип симуляции > Продолжительность > Полное время)
	2 [s]

	
	Simulation Type > Time Steps > Timesteps[b]
(Тип симуляции > Шаги по времени > Шаги по времени)
	0.025 [s]

	
	Simulation Type > Initial Time > Time
(Тип симуляции > Начальное значение времени > Время)
	0 [s]

	[a] Это продолжительность всей симуляции. 

[b] Это интервал времени между шагами. Симуляция будет продолжаться с шагом по времени равным 0.025 s до тех пор, пока не достигнет полного времени равного 2 s 


3. Нажмите OK. 

Создание домена 
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Вы будете моделировать полость с наклоном в 30°. Это можно сделать, задав компоненты вектора гравитации по вертикали и горизонтали, которые станут по умолчанию осями координат, как это показано на диаграмме сверху. 

Создание домена 

1. Выберите Insert > Domain (Вставка > Домен) в главном меню или нажмите Domain (Домен) [image: image4.png]


, задайте имя Buoyancy2D. 

2. Примените следующие настройки к объекту Buoyancy2D
	Вкладка
	Параметр
	Значение

	General Options
(Общие настройки)
	Basic Settings > Fluids List
(Основные настройки > Список жидких сред)
	Air at 25 C
(Воздух 25 С)

	
	Domain Models > Pressure > Reference Pressure 
(Модель домена > Давление > Относительное давление)
	1 [atm]

	
	Domain Models > Buoyancy > Option
(Модель домена > Buoyant > Опции)
	Buoyant

	
	Domain Models > Buoyancy > Gravity X Dirn.
(Модель домена > Buoyant > Гравитация по оси X)
	-4.9 [m s^-2]

	
	Domain Models > Buoyancy > Gravity Y Dirn. (Модель домена > Buoyant > Гравитация по оси Y)
	-8.5 [m s^-2]

	
	Domain Models > Buoyancy > Gravity Z Dirn.
(Модель домена > Buoyant > Гравитация по оси Z)
	0.0 [m s^-2][a]

	
	Domain Models > Buoyancy > Buoy. Ref. Temp.
(Модель домена > Buoyant > Buoy относительная температура)
	40 [C][b]

	Fluid Models
(Модель расчета течения жидкой среды)
	Heat Transfer > Option
(Перенос тепла > Опции)
	Thermal Energy
(Тепловая энергия)

	
	Turbulence > Option
(Турбулентность > Опции)
	None (Laminar)
Нет (Ламинарный)

	[a] Это создает для вектора гравитации симуляцию наклона полости 

[b] Убедитесь, что Вы не забыли изменить единицы измерения. Это приблизительный показатель температуры домена. 


3. Инициализация будет установлена с помощью Global Initialization (Глобальная инициализация) [image: image5.png]


., поэтому нет необходимости переходить на вкладку Initialization (Инициализация). 

4. Нажмите OK. 

Создание граничных условий 

Горячая и холодная стенки 

Вы создадите граничные условия для стенки с фиксированной температурой равной 75 C на верхней части полости, для этого:

1. Создайте граничное условие с именем hot (Горячий). 

2. Примените следующие настройки
	Вкладка
	Параметр
	Значение

	Basic Settings
(Основные настройки)
	Boundary Type (Тип границы)
	Wall (Стенка)

	
	Location (Участок)
	WALLHOT
(Горячая стенка)

	Boundary Details
(Детали)
	Heat Transfer > Option
(Перенос тепла > Опции)
	Temperature
(Температура)

	
	Heat Transfer > Fixed Temperature
(Перенос тепла > Постоянная температура)
	75 [C]


3. Нажмите OK. 

4. Создайте граничное условие с именем cold (Холодный). 

5. Примените следующие настройки
	Вкладка
	Параметр
	Значение

	Basic Settings
(Основные настройки)
	Boundary Type (Тип границы)
	Wall (Стенка)

	
	Location (Участок)
	WALLCOLD
(Холодная стенка)

	Boundary Details
(Детали)
	Heat Transfer > Option
(Перенос тепла > Опции)
	Temperature
(Температура)

	
	Heat Transfer > Fixed Temperature
(Перенос тепла > Постоянная температура)
	5 [C]


6. Нажмите OK. 

Плоскость симметрии 

Одна плоскость симметрии может быть использована для граничных условий передней и задней частей полости.

1. Создайте граничное условие с именем SymP (Плоскость симметрии). 

2. Примените следующие настройки
	Вкладка
	Параметр
	Значение

	Basic Settings
(Основные настройки)
	Boundary Typе
(Тип границы)
	Symmetry
(Симметрия)

	
	Location (Участок)
	SYMMET1, SYMMET2[a]

	[a] Удерживая клавишу <Ctrl>, выберите оба региона. 


3. Нажмите OK. 

Для остальных регионов будут применены граничные условия по умолчанию: адиабатическая стенка.

Настройка начальных значений 

вы зададите ниже начальные настройки с помощью опции Automatic with Value (Автоматически со значением), когда опишите нестационарную симуляцию. используя эту опцию, при первом запуске начальные условия примут заданные значения, а при последующем запуске будут использоваться результаты из файла данных. 

1. Нажмите Global Initialization (Глобальная инициализация) [image: image6.png]


.  

2. Примените следующие настройки
	Вкладка
	Параметр
	Значение

	Global Settings
(Глобальные настройки)
	Initial Conditions > Cartesian Velocity Components > Option
(Инициализация условий > Компоненты скорости > Опции)
	Automatic with Value
(Автоматически со значением)

	
	Initial Conditions > Cartesian Velocity Components > U
(Инициализация условий > Компоненты скорости > U)
	0 [m s^-1]

	
	Initial Conditions > Cartesian Velocity Components > V
(Инициализация условий > Компоненты скорости > V)
	0 [m s^-1]

	
	Initial Conditions > Cartesian Velocity Components > W
(Инициализация условий > Компоненты скорости > W)
	0 [m s^-1]

	
	Initial Conditions > Static Pressure > Relative Pressure
(Инициализация условий > Статическое давление > Относительное давление)
	0 [Pa]

	
	Initial Conditions > Temperature > Temperature
(Инициализация условий > Температура > Температура)
	5 [C]


3. Нажмите OK. 

Настройки выходных параметров 

1. Нажмите Output Control (Управление выходными данными)[image: image7.png]


. 

2. Нажмите на вкладке Trn Results (Временные результаты). 

3. Создайте новый объект Transient Results (Временные результаты) с именем по умолчанию.

4. Примените следующие настройки
	Вкладка
	Параметр
	Значение

	Trn Results
(Временные результаты)
	Transient Results > Transient Results 1 > Option
(Временные результаты > Временные результаты 1 > Опции)
	Selected Variables
(Выбрать переменные)

	
	Transient Results > Transient Results 1 > Output Variables List
(Временные результаты > Временные результаты 1 > Список выходных переменных)
	Pressure, Temperature, Velocity
(Давление, температура, скорость)

	
	Transient Results > Transient Results 1 > Output Frequency > Option
(Временные результаты > Временные результаты 1 > Повторяемость выходных данных > Опции)
	Time Interval
(Временной интервал)

	
	Transient Results > Transient Results 1 > Output Frequency > Time Interval
(Временные результаты > Временные результаты 1 > Повторяемость выходных данных > Временной интервал)
	0.1 [s]


5. Нажмите OK. 

Настройки параметров решателя 

1. Нажмите Solver Control (Контроль решателя) [image: image8.png]


. 

2. Примените следующие настройки
	Вкладка
	Параметр
	Значение

	Basic Settings
(Основные настройки)
	Advection Scheme > Option
(Схема адвекции)
	High Resolution
(Высокая точность)

	
	Convergence Control > Max. Coeff. Loops
(Управление сходимостью > Максимальный коэффициент итераций)
	5

	
	Convergence Criteria > Residual Type
(Критерий сходимости > Тип остатка)
	RMS

	
	Convergence Criteria > Residual Target
(Критерий сходимости > Цель остатка)
	1.E-4[a]

	[a] В численном методе RMS значение меньше чем 1.E-5 обычно означает адекватную сходимость, но значение по умолчанию устанавливает осмысленное значение для сходимости.


3. Нажмите OK. 

Запись файла для решателя (.def) 

1. Нажмите Write Solver File (Записать файл для решателя) [image: image9.png]


. 
2. Примените следующие настройки:

	Параметр
	Значение

	File name
(Имя файла)
	Buoyancy2D.def

	Quit CFX–Pre[a]
(Закрыть CFX–Pre)
	(Поставьте галочку)

	[a] Если запустили ANSYS CFX-Pre из ANSYS CFX-.11.0 Laucher.  


3. Убедитесь что выбран пункт Start Solver Manager (Запустить Менеджер задач) и нажмите Save (Сохранить).  

4. Если вы получили сообщение о том, что файл уже существует, нажмите Overwrite (Перезаписать). 

5. Нажмите Yes (Да) или Save & Quit (Сохранить и закрыть приложение), чтобы сохранить файл с расширением (.cfx). 

Получение решения с помощью ANSYS CFX-Solver Manager
Когда завершится приложение ANSYS CFX-Pre и запустится ANSYS CFX-Solver Manager, Вы можете решить задачи вычислительной гидродинамики (CFD) с помощью следующих действий.

Примечание
Обратите внимание, что выходной файл в ANSYS CFX-Solver Manager на вкладке Out File более сложный для нестационарной задачи, чем для стационарной. Каждый шаг состоит из нескольких итераций и для каждого шага печатается информация величинах. 

1. Нажмите Start Run (Запустить расчет). 

2. Нажмите Yes to post-process the results when the completion message appears at the end of the run. 

3. If using Standalone Mode, quit ANSYS CFX-Solver Manager.
Просмотр результатов в постпроцессоре ANSYS CFX-Post 

В этом примере Вы создадите отчет в ANSYS CFX-Post. Вы также создадите анимацию и увидите изменение температуры во времени.

Простой отчет 

1. Нажмите на вкладку Report Viewer (Просмотр отчета). Заметим, что отчет загрузился со статической информацией сгенерированной автоматически. 

2. На вкладке Outline дерева просмотра под пунктом Report (Отчет) поэкспериментируйте с различными настройками для Mesh Report (Отчет по сетке), Physics Report (Отчет по физике) и другими объектами отчетов. Эти настройки управляют содержанием отчета. На вкладке Report Viewer (Просмотр отчета) нажмите на Refresh (Обновить), чтобы увидеть изменения Вашего отчета. 

Графики 

Здесь Вы создадите вспомогательный объект для дальнейшей генерации пользовательского отчета:

· Контурный график температуры
· Множества точек (для наблюдения за температурой)

· Комментарий
· Рисунки контурного графика и множества точек
· Временная диаграмма, показывающая температуру в точках
· Таблица
Контурный график 

1. Нажмите на вкладку 3D Viewer (Окно просмотра 3D объекта) и нажмите правую кнопку мыши в области окна просмотра и выберите пункт Predefined Camera > View Towards -Z (Расположение камеры > Просмотр по направлению оси Z).
2. Выберите в главном меню Insert > Contour (Вставка > Контур). 

3. Примите имя по умолчанию, нажав кнопку OK. 

4. Укажите участок Locations SymP. 

5. Укажите переменную Variable Temperature (Тепмература). 

6. Нажмите Apply (Применить). 

График контура показывает температуру в конце симуляции, так как ANSYS CFX-Post по умолчанию загружает значения, которые принимают величины на последнем шаге. Вы можете загрузить результаты любого шага с помощью диалогового окна Timestep Selector (Выбор шага), которое доступно из главного пункта меню Tools > Timestep Selector. 

Множество точек 

1. Выберите из главного меню пункт Insert > Location > Point (Вставка > Участок > Точка). 

2. Примите имя по умолчанию, нажав кнопку OK. 

3. Укажите значение параметра Method (Метод) равное XYZ. 

4. Укажите координаты точки Point 0.098, 0.05, 0.00125. 

5. Нажмите Apply (Применить). 

Точка Point 1 появится в окне просмотра. 

6. Нажмите правой кнопкой мыши на объекте Point 1 в дереве просмотра и выберите из контекстного меню пункт Duplicate (Дубликат). 

7. Примите имя по умолчанию, нажав кнопку OK. 

8. Нажмите правой кнопкой мыши на объекте Point 2 в дереве просмотра и выберите из контекстного меню пункт Edit (Правка). 

9. Измените значение по x на 0.052. 

10. Нажмите Apply (Применить). 

Точка Point 2 появится в окне просмотра. 

Комментарий 

1. Нажмите Cteate comment (Создать комментарий). 

2. Примите имя по умолчанию, нажав кнопку OK. 

Под объектом Report (Отчет) в дереве просмотра появится объект комментария. 

3. Установите параметру Heading (Заголовок) значение Buoyant Flow in a Partitioned Cavity (Течение потока воздуха в разделенной полости). 

4. В большом поле для ввода напишите:

This is a sample paragraph (Это пример абзаца).
Рисунок
1. Перейдите на вкладку 3D Viewer (Просмотр 3D объекта). 

2. Выберите в главном меню пункт Insert > Figure (Вставка > Рисунок). 

3. Примите имя по умолчанию, нажав кнопку OK. 

Поставьте галочку для параметра Make copies of objects (Создать копию объекта) или скопируйте объект, который видим в окне просмотра. Если объект скопирован, то используете копию, а не оригинал. Так как Вы не используете несколько окон просмотра, меняйте настройки объекта, который не имеет большого значения.
not the objects that are visible in the viewer are copied. If objects are copied, then the copies are used in the figure instead of the originals. Since you are not using multiple views or figures, the check box setting does not matter. 

Рисунок появится под объектом Report (Отчет) в дереве просмотра. 

Диаграмм по времени 

1. Выберите в главном меню пункт Insert > Chart (Вставка > Диаграмма). 

2. Примите имя по умолчанию, нажав кнопку OK.
3. Укажите значение параметра Title (Заголовок) равным Temperature versus Time (Температура в сравнении со временем). 

4. Укажите значение параметра Type (Тип) Time (Время). 

5. Нажмите на вкладку Chart Line 1 (Линия на диаграмме). 

6. Укажите значение параметра Line Name (Имя линии) Temperature at Point 1 (Температура в точке 1). 

7. Укажите значение параметра Method (Метод) Point (Точка). 

8. Укажите значение параметра Location (Участок) Point 1 (Точка 1). 

9. Укажите значение параметра Time Variable > Variable (Переменная по времени > Переменная) Temperature (Температура). 

10. Нажмите Apply (Применить). 

Диаграмма появится под объектом Report (Отчет) в дереве просмотра. Также диаграмм сама отобразится на вкладке Chart Viewer (Окно просмотра диаграмм). Это может занять некоторое время, поскольку для создания дианраммы необходимо по очереди загрузить все временные файлы. 

11. Нажмите New Line (на вкладке Chart Line 1). 

12. Укажите значение параметра Line Name (Имя линии) Temperature at Point 2 (Температура в точке 2). 

13. Установите значение параметра Location (Участок) Point 2 (Точка 2) и параметру Time Variable > Variable (Переменная по времени > Переменная) значение Temperature (Температура). 

14. Нажмите Apply (Применить). 

На диаграмме появится вторая линия, показывающая температуру в точке Point 2. 

Таблица 

1. Выберите из главного меню пункт Insert > Table (Вставка > Таблица). 

2. Примите имя по умолчанию, нажав кнопку OK. 

Объект таблицы появится под пунктом Report (Отчет) в дереве просмотра. 

3. Примените следующие настройки:

	Ячейка
	Значение

	A1
	Location (Участок)

	A2
	Point 1 (Точка 1)

	A3
	Point 2 (Точка 2)

	B1
	Temperature (Температура)

	B2
	=probe(Temperature)@Point 1

	B3
	=probe(Temperature)@Point 2


Таблица показывает температуры в конце симуляции, так как ANSYS CFX-Post по умолчанию загружает значения, которые принимают величины на последнем шаге. Вы можете загрузить результаты любого шага с помощью диалогового окна Timestep Selector (Выбор шага), которое доступно из главного пункта меню Tools > Timestep Selector. 

Пользовательский отчет
Нажмите правой кнопкой мыши на объекте Report и выберите из контекстного меню пункт Refresh (Обновить). Взгляните на отчет на вкладке Report Viewer (Просмотр отчета). Обратите внимание на то, что в дополнение к автоматически созданным объектам, которые Вы видели ранее, этот отчет также содержит рисунок, временную диаграмму и таблицу, описанные выше. 

Анимация 

Для создания анимации воспользуйтесь примером 4. 

Завершение
Когда завершите работу, закройте ANSYS CFX-Post.

